+ Reply to Thread
Results 1 to 6 of 6

Error found in Custom UI XML

  1. #1
    Registered User
    Join Date
    10-05-2010
    Location
    South Africa
    MS-Off Ver
    Excel 2007
    Posts
    6

    Error found in Custom UI XML

    Good Day,

    I have created a Custom UI XML Ribbon that I always load on start up of my spreadsheet. Things have been going fine until I installed Visual Studio 2008. Since then I am getting this error when I open up my spreadsheet:

    Error found in Custom UI XML of "ExcelWorkbook2.xlsm":

    Line: 84
    Column: 97
    Error Code 0x80004005
    Unknown Office control ID: NewTab


    1) I know that I can turn off Excel addin warnings. But I do not want to do this.
    2) And I would like to keep VS2008 installed, as I am trying out some ribbon customizations from there too.

    What is causing this problem ?

    Thank you
    Shaun
    Kelly

  2. #2
    Registered User
    Join Date
    10-05-2010
    Location
    South Africa
    MS-Off Ver
    Excel 2007
    Posts
    6

    Re: Error found in Custom UI XML

    Hi All,

    I think I have solved the problem. I removed all the [ "insertAfterMso="MyExtraControls2" ] attributes from my custom tabs and groups. I could then successfully open my spreadsheet with its new ribbon.

    1) The question I now have is: how do I then guarantee the order in which my tabs and their groups are created ?

    Thank you
    Shaun

  3. #3
    Forum Guru romperstomper's Avatar
    Join Date
    11-04-2008
    Location
    A1
    MS-Off Ver
    Most
    Posts
    12,302

    Re: Error found in Custom UI XML

    I believe they are created in the order they appear in your XML, unless you specify otherwise.
    Remember what the dormouse said
    Feed your head

  4. #4
    Forum Guru Andy Pope's Avatar
    Join Date
    05-10-2004
    Location
    Essex, UK
    MS-Off Ver
    2003, 2007, 2010 & 2013
    Posts
    18,131

    Re: Error found in Custom UI XML

    your have used a non built-in name with which to position you control.

    insertAfterMso expects a predefined mso value.

    As RS says custom items will appear in the order specified and after any built-in items.
    Cheers
    Andy
    www.andypope.info

  5. #5
    Registered User
    Join Date
    10-05-2010
    Location
    South Africa
    MS-Off Ver
    Excel 2007
    Posts
    6

    Re: Error found in Custom UI XML

    Hi Andy, RS,

    Thank you for the confirmation about the order of custom objects and the limitation of what values can be used with the "insertAfterMso" attribute.
    I assumed that my custom tab/group's id would have been added to the mso name list, so that I could reference them when needed.

    Regards
    Shaun

  6. #6
    Forum Guru Andy Pope's Avatar
    Join Date
    05-10-2004
    Location
    Essex, UK
    MS-Off Ver
    2003, 2007, 2010 & 2013
    Posts
    18,131

    Re: Error found in Custom UI XML

    You can not add your id to the mso list. You have to position your controls relative to mso ones.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1