+ Reply to Thread
Results 1 to 4 of 4

Receiving error when trying to use AVERAGE fx to average cells containing results of IF fx

  1. #1
    Registered User
    Join Date
    08-21-2018
    Location
    Atlanta
    MS-Off Ver
    10
    Posts
    2

    Receiving error when trying to use AVERAGE fx to average cells containing results of IF fx

    I'm receiving a DIV/0 error when I try to average two cells using the AVERAGE function, both of the cells contain numbers that are a result of an of a previous IF function...

    Does anyone know a way to solve this without just C&P the actual numbers into the cells? This is part of a model, so I do not want to hardcode numbers - it needs to be dynamic.

    Thank you!

  2. #2
    Forum Guru TMS's Avatar
    Join Date
    07-15-2010
    Location
    The Great City of Manchester, NW England ;-)
    MS-Off Ver
    MSO 2007,2010,365
    Posts
    36,252

    Re: Receiving error when trying to use AVERAGE fx to average cells containing results of I

    That's not much to go on. What are the IF functions that produce the values in the cells you are trying to average? If the result is a value that is text but it looks like a number, you will get a #DIV/0!
    Trevor Shuttleworth - Excel Aid

    I dream of a better world where chickens can cross the road without having their motives questioned

    'Being unapologetic means never having to say you're sorry' John Cooper Clarke


  3. #3
    Registered User
    Join Date
    08-21-2018
    Location
    Atlanta
    MS-Off Ver
    10
    Posts
    2

    Re: Receiving error when trying to use AVERAGE fx to average cells containing results of I

    Great - thanks, I had used quotations in the IF function making the numbers text. Solved.

  4. #4
    Forum Guru TMS's Avatar
    Join Date
    07-15-2010
    Location
    The Great City of Manchester, NW England ;-)
    MS-Off Ver
    MSO 2007,2010,365
    Posts
    36,252

    Re: Receiving error when trying to use AVERAGE fx to average cells containing results of I

    You're welcome. Thanks for the rep.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SumProduct N/A Error, Quarterly Average, Running Average, From and to Userform
    By Sorjas in forum Excel Programming / VBA / Macros
    Replies: 9
    Last Post: 01-18-2015, 07:40 PM
  2. [SOLVED] Error Handling #N/A with AVERAGE Function - Average of values in Row
    By Don Guillett in forum Excel Formulas & Functions
    Replies: 78
    Last Post: 09-06-2005, 07:05 PM
  3. Error Handling #N/A with AVERAGE Function - Average of values in Row
    By Sam via OfficeKB.com in forum Excel Formulas & Functions
    Replies: 0
    Last Post: 09-06-2005, 06:05 PM
  4. Error Handling #N/A with AVERAGE Function - Average of values in Row
    By Sam via OfficeKB.com in forum Excel Formulas & Functions
    Replies: 0
    Last Post: 09-06-2005, 03:05 PM
  5. Error Handling #N/A with AVERAGE Function - Average of values in Row
    By Sam via OfficeKB.com in forum Excel Formulas & Functions
    Replies: 0
    Last Post: 09-06-2005, 10:05 AM
  6. [SOLVED] Error Handling #N/A with AVERAGE Function - Average of values in Row
    By Don Guillett in forum Excel Formulas & Functions
    Replies: 26
    Last Post: 09-06-2005, 07:05 AM
  7. [SOLVED] Error Handling #N/A with AVERAGE Function - Average of values in Row
    By Sam via OfficeKB.com in forum Excel Formulas & Functions
    Replies: 0
    Last Post: 09-05-2005, 11:05 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1