+ Reply to Thread
Results 1 to 2 of 2

Excel acting strangely with macro enabled files: odd errors, standard methods not working

  1. #1
    Forum Contributor
    Join Date
    10-01-2018
    Location
    Virginia Beach, VA
    MS-Off Ver
    Excel 2013
    Posts
    111

    Excel acting strangely with macro enabled files: odd errors, standard methods not working

    I’m trying to help a co-worker with an issue she’s experiencing in Excel but I’m drawing a blank, and the IT department can't seem to figure it out either. (Their solution is to order a new computer, LOL...) Any time she opens a file that has macros enabled, it appears that Excel isn’t reading the file properly, and then it removes worksheet properties from various sheets within the workbook.

    Opening a macro-enabled file generates this error:

    1.png

    Clicking “Yes” brings up this notification:

    2.png

    The linked log file reads the following: (posted here as a screenshot from my email to IT... the board rejected it as text due to html content, even inside code tags)

    5.png

    After closing the above notification, the code in the file runs... but it errors out, kicking back the following code error:

    3.png

    The highlighted method that is generating this error is the first instance of “UsedRange.Clear”, in the code section below:

    4.png

    This code has been working fine on this computer until a few days ago, and there should have been no reason for anything to change in the system settings or in the registry. I have tried adjusting the macro security settings, but nothing makes a difference.

    It appears to me based on this and other errors I’m getting, that for some reason her copy of Excel is not recognizing standard methods and worksheet properties. This may be due to an error in the registry, or just an internal Excel error… I don’t have a clue. Does anyone have any idea what might be causing the issue?

    Thanks!

  2. #2
    Forum Moderator 6StringJazzer's Avatar
    Join Date
    01-27-2010
    Location
    Tysons Corner, VA, USA
    MS-Off Ver
    Pro 2019
    Posts
    14,664

    Re: Excel acting strangely with macro enabled files: odd errors, standard methods not work

    I have seen this but only in individual files. If it is happening to one macro-enabled file then I would say the file is corrupted. If it is happening to every macro-enabled file then I would say the installation of Excel is corrupted.

    I assume that you have copied and opened the same files successfully on another machine. If not you should try that, making sure you have gotten a clean copy that hasn't been repaired yet.

    If I were Microsoft Tech Support I would tell you to uninstall and reinstall Office. The macro error is probably happening because of the Worksheet features that were removed to recover the file.
    Making the world a better place one fret at a time | | |·| |·| |·| |·| | |:| | |·| |·|
    Please read the rules
    If someone helped you, click on the star icon at the bottom of their post
    If your problem is solved, go to Thread Tools and select Mark This Thread Solved
    Don't attach a screenshot--just attach your Excel file! It's easier and will let us experiment with your data, formulas, and code.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1