+ Reply to Thread
Results 1 to 6 of 6

Hyperlink buttons don't work out of design mode.

  1. #1
    Registered User
    Join Date
    08-02-2009
    Location
    Cambridge, England
    MS-Off Ver
    Excel 2003
    Posts
    10

    Angry Hyperlink buttons don't work out of design mode.

    I've been developing a spreadsheet to control a charity's accounts. Comprising of many separate sheets I thought it appropriate to have hyperlinks embedded in push buttons. I have also put in push buttons assigned to a macro that clears data.

    Unfortunately and very frustratingly I cannot get the two to work together in harmony. The h-links work fine on opening but not the macro buttons, until I click 'enable macros', then the page works in visa versa, macros work, h'links don't.

    I know why this is, by using the macros design mode is automatically switched off. This can be easily remedied by turning the design mode back on. However this workbook is intended for for use by many other people and it will be a pain having to instruct them all on how to add the developer setting to the ribbon, activate design mode blah blah blah. Is there any getting round this???
    Attached Files Attached Files

  2. #2
    Forum Moderator Paul's Avatar
    Join Date
    02-05-2007
    Location
    Wisconsin
    MS-Off Ver
    2016/365
    Posts
    6,881

    Re: Hyperlink buttons don't work out of design mode.

    Hi Achtung_boy, welcome to the forum.

    Instead of using hyperlinks with command buttons, why not just use a macro behind the command buttons? You just need to go into design mode, right click on each 'Home' button and choose View Code. Add the following one line of code to each:
    Please Login or Register  to view this content.
    Also, your delete macro could be simplified to:
    Please Login or Register  to view this content.
    Or even
    Please Login or Register  to view this content.
    Last edited by Paul; 08-02-2009 at 08:46 PM.

  3. #3
    Forum Guru martindwilson's Avatar
    Join Date
    06-23-2007
    Location
    London,England
    MS-Off Ver
    office 97 ,2007
    Posts
    19,320

    Re: Hyperlink buttons don't work out of design mode.

    what i want to know is how the heck do you asign a hyperlink to a command button?
    once out of design mode it can only do the command button click event anyway.
    "Unless otherwise stated all my comments are directed at OP"

    Mojito connoisseur and now happily retired
    where does code go ?
    look here
    how to insert code

    how to enter array formula

    why use -- in sumproduct
    recommended reading
    wiki Mojito

    how to say no convincingly

    most important thing you need
    Martin Wilson: SPV
    and RSMBC

  4. #4
    Registered User
    Join Date
    08-02-2009
    Location
    Cambridge, England
    MS-Off Ver
    Excel 2003
    Posts
    10

    Re: Hyperlink buttons don't work out of design mode.

    Many thanks Paul. That was a great help. Cheers

  5. #5
    Forum Expert royUK's Avatar
    Join Date
    11-18-2003
    Location
    Derbyshire,UK
    MS-Off Ver
    Xp; 2007; 2010
    Posts
    26,202

    Re: Hyperlink buttons don't work out of design mode.

    Your post does not comply with Rule 5 of our Forum RULES. We have Seven question forums: Miscellaneous, General, Programming, Worksheet Functions, Charting, Excel 2007 Help and New Users. Please choose the appropriate forum, and post your question in ONLY one forum.

    Note moved from Excel 2007 Forum
    Hope that helps.

    RoyUK
    --------
    For Excel Tips & Solutions, free examples and tutorials why not check out my web site

    Free DataBaseForm example

  6. #6
    Forum Expert royUK's Avatar
    Join Date
    11-18-2003
    Location
    Derbyshire,UK
    MS-Off Ver
    Xp; 2007; 2010
    Posts
    26,202

    Re: Hyperlink buttons don't work out of design mode.

    If you are satisfied with the solution(s) provided, please mark your thread as Solved.

    How to mark a thread Solved
    Go to the first post
    Click edit
    Click Go Advanced
    Just below the word Title you will see a dropdown with the word No prefix.
    Change to Solved
    Click Save

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1