+ Reply to Thread
Results 1 to 4 of 4

Macro to email XL attachments (files are not attached)

  1. #1
    Registered User
    Join Date
    03-05-2010
    Location
    Essex, England
    MS-Off Ver
    Excel 2003
    Posts
    58

    Macro to email XL attachments (files are not attached)

    Hi there,

    I've found a macro on line which will send emails with attachments. The problem I have is that the macro does not pick up the file attachment and I can't work out why. I have tried two macros and seem to have the same problem.

    I have attached the macro that I'm attempting to use.

    Would someone be able to explain where I'm going wrong?

    Thanks in anticipation
    Bobbi
    Attached Files Attached Files

  2. #2
    Forum Guru TMS's Avatar
    Join Date
    07-15-2010
    Location
    The Great City of Manchester, NW England ;-)
    MS-Off Ver
    MSO 2007,2010,365
    Posts
    37,218

    Re: Macro to email XL attachments (files are not attached)

    The first file is missing a file extension.

    The second file may not exist.

    The code works for me unchanged. I just added valid path/file names into the cells.


    Regards, TMS

  3. #3
    Registered User
    Join Date
    03-05-2010
    Location
    Essex, England
    MS-Off Ver
    Excel 2003
    Posts
    58

    Re: Macro to email XL attachments (files are not attached)

    Hi TMS

    Thanks for your quick response.

    Yes, I did notice that after I sent it and have amended it but to no avail.

    I'm going to test it on my other laptop (not work) to see if it has anything to do with security or settings.

    Thanks
    Bobbi

  4. #4
    Forum Guru TMS's Avatar
    Join Date
    07-15-2010
    Location
    The Great City of Manchester, NW England ;-)
    MS-Off Ver
    MSO 2007,2010,365
    Posts
    37,218

    Re: Macro to email XL attachments (files are not attached)

    Not much I can add really. Step through the code and check what is being picked up and confirm that the location and file both exist.

    As I say, works fo rme without change so it is something to do with your data or environment.

    Regards, TMS

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1