Hello guys. I have an auxiliary file I use to automate some cleanup and arrange of data. I noted the text to column in a VBA step works for all lines save for the last row, disregarding of the amount of rows it leaves the last one unmodified.
I have also a list of find and replace and I noted some cases needed replacement so I checked if those were included in my list of if I needed to add them for future cases but to my surprise there are cases where it should have worked, it was already listed in the VBA find and replace.
I proceeded to change them manually and I noted when I press Ctrl+f and select to replace the text I need to delete (i replace with with nothing) it does nothing, literally nothing. I try just finding the text, nothing. I check there is no parameter that might interfere, "match case" unchecked, "match entire cell content" unchecked, still nothing. I even tried using Find with other things, entire cell contents, words, even letters, it does nothing. It's like it stopped working after the VBA code run, which weirdly did change all other cases (got 16 of them). Another thing I noted is that if I copy a cell it no longer shows the borders marked as usually does with copied ranges although it pastes it with no problem.
Saved the file, closed it, opened it again and Find and Replace worked again.

Anybody else experienced this?
The problem I have with this is that my VBA code loses effect, because I cannot just run it again and have to manually change those cases still in need to be changed.