+ Reply to Thread
Results 1 to 4 of 4

Upgrading from Windows 7 to 10 solver macro don't work

  1. #1
    Forum Expert
    Join Date
    03-13-2004
    Location
    Gothenburg/Stockholm, Sweden
    MS-Off Ver
    Excel 2003, Excel 2007 & reluctant Excel 2010 user
    Posts
    4,410

    Upgrading from Windows 7 to 10 solver macro don't work

    I did an upgrade from Windows 7 to Windows 10 but all of sudden all macros using solver stopped working.

    Running solver as a standalone do not work either as program complain about not finding solver.dll file. Checking the folder for Microsoft office I see that most of the files in the excel folder is gone. A reinstallation of Excel does not add the missing files.

    Anybody has had this problem? The excel 2010 program has worked flawlessly for a number of years with Windows 7 as OS.

    Alf

  2. #2
    Forum Expert
    Join Date
    10-06-2017
    Location
    drevni ruchadlo
    MS-Off Ver
    old
    Posts
    1,441

    Re: Upgrading from Windows 7 to 10 solver macro don't work

    Did you check here ?
    https://www.solver.com/excel-solver-online-help
    ...

    If there is no answer, then you will probably need to use:

    1. some kind of program "Find and repair DLL errors" (??? ... hmm maybe not ...)
    or
    2. "Completely uninstall Office with the uninstall support tool"
    https://support.office.com/en-us/art...rs=en-US&ad=US
    and
    3. clean the computer/registry ("tools suitable for this", see internet) and install from the "clean" beginning

  3. #3
    Forum Expert
    Join Date
    03-13-2004
    Location
    Gothenburg/Stockholm, Sweden
    MS-Off Ver
    Excel 2003, Excel 2007 & reluctant Excel 2010 user
    Posts
    4,410

    Re: Upgrading from Windows 7 to 10 solver macro don't work

    Hi porucha vevrku

    Thank for you suggestions but the strange thing is that when I started my PC this morning I got the message "Wait while Microsoft updates your PC" so after this update I tested solver and now it works as it should do.

    Don't know if there is a time element in what happened or the PC needs a number of restarts before everything is in order but it works.

    I've also checked the "Windows.Old" folder that gets created when one do an upgrade of OS but I have not seen anything in the subfolders related to "excel 2010" and hopefully this is so as the "Windows.Old" folder normally gets deleted after 30 days. As this folder uses 31.7 Gb of my C drive I'll be happy to see it go unless something I do use disappear as well. Perhaps I should move it to another drive just to be safe.

    Alf

  4. #4
    Registered User
    Join Date
    02-12-2020
    Location
    KL, Malaysia
    MS-Off Ver
    14.0
    Posts
    1

    Re: Upgrading from Windows 7 to 10 solver macro don't work

    thank you for this

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1