+ Reply to Thread
Results 1 to 3 of 3

Onmogelijk? Aantal.als tellen uit 3 verschillende kolommen met twee voorwaardes

  1. #1
    Registered User
    Join Date
    02-13-2015
    Location
    Amsterdam
    MS-Off Ver
    2010
    Posts
    1

    Question Onmogelijk? Aantal.als tellen uit 3 verschillende kolommen met twee voorwaardes

    Help Mij Google kon mij niet helpen: Ik wil het aantal keren tellen, dat er een storing op een bepaalde machine voorkomt. Voor het excelforum heb ik een apart Excelbestand aangemaakt. Als je dit document gaat tellen, kom je op 8 storingen uit. Het originele bestand bestaat uit honderden rijen en meer kolommen, dus handmatig is onmogelijk.

    Ik wil het aantal keren tellen dat er een storing voorkomt, per machine. (Het gaat om machine 6 en 7)
    Nu heb ik geprobeerd dit op te lossen met =AANTAL.ALS(C2:C8;B2:B8=6)+AANTAL.ALS(G2:G8;B2:B8=6)+AANTAL.ALS(K2:K8;B2:B8=6), zie bijlage.


    Ik las nog iets over Somproduct, maar daar begrijp ik weinig van. Ik ben ten einde raad en kan er serieus niet van slapen. Wie is mijn redder in nood? Alvast super bedankt!


    HelpMij Aantal.als problematiek.xlsx

  2. #2
    Forum Expert
    Join Date
    05-30-2012
    Location
    The Netherlands
    MS-Off Ver
    Excel 2016
    Posts
    13,764

    Re: Onmogelijk? Aantal.als tellen uit 3 verschillende kolommen met twee voorwaardes

    Met een hulpkolom.

    Daarna een draaitabel.

    Zie de bijlage.

    P.s. werk niet met samengevoegde cellen, daar krijg je vroeger of later last van.

    Crossposting is niet toegestaan op dit forum.

    De naam van je bestand had me op het idee kunnen brengen (maar heeft dat later pas gedaan).

    http://www.helpmij.nl/forum/showthre...ee-voorwaardes
    Attached Files Attached Files
    Last edited by oeldere; 02-13-2015 at 10:16 AM.
    Notice my main language is not English.

    I appreciate it, if you reply on my solution.

    If you are satisfied with the solution, please mark the question solved.

    You can add reputation by clicking on the star * add reputation.

  3. #3
    Registered User
    Join Date
    06-22-2015
    Location
    Hilversum, Netherlands
    MS-Off Ver
    2007
    Posts
    12

    Re: Onmogelijk? Aantal.als tellen uit 3 verschillende kolommen met twee voorwaardes

    Hoi myrose,

    Ik heb de volgende formule bedacht: =SOMPRODUCT(((D2:D8<>"")+(H2:H8<>"")+(L2:L8<>""))*(B2:B8=6))
    Ik zou adviseren om in plaats van drie storingen naast elkaar te zetten, voor elke storing een aparte rij te gebruiken. Dat maakt het denk ik een stuk eenvoudiger.

    Met vriendelijke groet,
    Maarten

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Twee lijsten samenvoegen met een gemeenschappelijke loom
    By Joervlas in forum Non English Excel
    Replies: 0
    Last Post: 03-20-2013, 07:59 AM
  2. Aantal cellen met de voorwaarde uit twee kolommen.
    By NickHindriks in forum Non English Excel
    Replies: 5
    Last Post: 03-01-2012, 11:45 AM
  3. Gegevens uit twee tabbladen
    By AieSch in forum Non English Excel
    Replies: 4
    Last Post: 07-03-2011, 07:31 AM
  4. Tellen van cellen indien een lettercombinatie overeenkomt
    By JoostBoost in forum Non English Excel
    Replies: 1
    Last Post: 07-15-2009, 07:58 AM
  5. aantal.als - Countif
    By lesage in forum Excel Formulas & Functions
    Replies: 5
    Last Post: 12-16-2006, 01:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1