+ Reply to Thread
Results 1 to 3 of 3

Ajouter des champs vides dans une numérotation

  1. #1
    Registered User
    Join Date
    02-17-2015
    Location
    Canada
    MS-Off Ver
    2008
    Posts
    4

    Ajouter des champs vides dans une numérotation

    Salut!
    Je me sers rarement d'Excel. En ce moment, je cherche comment faire une base de données avec plusieurs lignes vide ou avec des xxx ou des 0000. Ma liste contient 500 000 numéro donc j'essaie de trouver un moyen de le faire automatiquement. Avez-vous une idée comment faire? Merci.

    Exemple:
    01
    02
    03
    04
    05
    06
    07
    08
    09
    10
    00
    00
    00
    00
    00
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    00
    00
    00
    00
    00
    21
    22
    23
    24
    25
    etc...

  2. #2
    Registered User
    Join Date
    05-07-2015
    Location
    Angouleme, France
    MS-Off Ver
    2013
    Posts
    48

    Re: Ajouter des champs vides dans une numérotation

    Bonjour,

    Si j'ai bien compris, tu veux ajouter 5 lignes vides toutes les 10 lignes ?

    Si tu n'es pas réticent au VBA tu peux essayer cette macro :

    Please Login or Register  to view this content.
    Dit moi si ça te convient

    François

    EDIT : Pour 500 lignes, ça fonctionne parfaitement. Pour 500 000, ça risque d'être, disons, un peu plus long !
    Last edited by AstroZelda; 06-03-2015 at 09:02 AM.

  3. #3
    Forum Contributor
    Join Date
    07-13-2015
    Location
    Quebec, Canada
    MS-Off Ver
    2013
    Posts
    232

    Re: Ajouter des champs vides dans une numérotation

    Met 1 à 10 manuellement dans A1-A10 et entre ca dans A11, colle pour le reste en bas

    =SI(SOMME(A6:A10)=0;A5+1;SI(ET(SOMME(A7:A10)=0;A6<>0);0;SI(ET(SOMME(A8:A10)=0;A7<>0);0;SI(ET(SOMME(A9:A10)=0;A8<>0);0;SI(ET(A10=0;A9<>0);0;SI(NB.SI(A1:A10;0)=0;0;A10+1))))))

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Insérer un *.jpg dans un PPT depuis un USF Excel
    By Damdam69 in forum Non English Excel
    Replies: 0
    Last Post: 02-10-2014, 06:56 PM
  2. Eliminer doublons dans macro tirage
    By MARGAR in forum Non English Excel
    Replies: 0
    Last Post: 05-10-2012, 08:32 AM
  3. [SOLVED] Bouton inaccessible dans Excel 2002
    By sophie.nicolas@sigt.fr in forum Excel Programming / VBA / Macros
    Replies: 1
    Last Post: 01-19-2006, 03:20 PM
  4. fonction SI + max dans la meme cellule
    By lo in forum Excel General
    Replies: 1
    Last Post: 08-05-2005, 10:29 AM
  5. 2 question for Excel champs ;)
    By hummiz in forum Excel General
    Replies: 6
    Last Post: 06-02-2005, 12:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1