+ Reply to Thread
Results 1 to 3 of 3

Usar texto(endereço absoluto) presente em uma célula como critério em outras fórmulas

  1. #1
    Registered User
    Join Date
    09-22-2021
    Location
    Brasil
    MS-Off Ver
    365
    Posts
    2

    Question Usar texto(endereço absoluto) presente em uma célula como critério em outras fórmulas

    Tenho uma planilha onde tem muitas linhas (+de 60k no momento) fiz uma fórmula que faz SOMASES e CONTASES baseado na data, ou seja, ela conta quantas vezes uma determinada máquina parou por quebra, e soma o tempo de parada dessas máquinas. Ex: uma parou duas vezes e somou 45 min, mas tem mais paradas que não são por quebra e muitas outras máquinas. Ao declarar o alcance das fórmulas SOMASES e CONTASES eu selecionei várias células do início ao fim de uma certa data, mas como são muitas detas e muitas linhas por datas, é complicado alterar a fórmula sempre, portanto dei um jeito de usar um SE(CÉL()) para mostrar o valor absoluto do início e fim dos intervalos que eu vou precisar de cada célula.
    itjustworks.PNG
    Como pode ver na imagem acima as células estão com o exato texto que eu preciso colocar nos ranges das funções CONTASES e SOMASES. Ex de como está(No caso o range da coluna "O" não está feito/presente no print):
    CONT.SES($J$61381:$J$61498;J61459; $K$61381:$K$61498;"Quebra")
    (SOMASES($O$61381:$O$61498;$J$61381:$J$61498;J61459;$K$61381:$K$61498;"Quebra")*0,0166667)
    Eu quero substituir os "$J$61381:$J$61498"s pelas células que tem como resultado da fórmula(=SE(OU(AB61459<>AB61458);CÉL("endereço";J61459);AC61458) ) os ditos endereços.

    PS: Só por desencargo segue a fórmula inteira atual nas células(Já está bem extenso, e que fique mais, contanto que funcione(Neste momento já funciona, mas o trabalho manual de redefinir os ranges por data é complexo e estou bem próximo de não ter mais que fazê-lo)):
    =SE(OU(E(J61459=J61458;K61459<>"Quebra");K61459<>"Quebra";E(K61459=K61458;J61459=J61458));"";((SE(OU(I61458="GD's";I61458="Secador";I61458="Seladores Termoplásticos Agrupada";I61458="Seladores Termoplásticos Drops");10;12))-(SOMASES($O$61381:$O$61498;$J$61381:$J$61498;J61459;$K$61381:$K$61498;"Quebra")*0,0166667))/CONT.SES($J$61381:$J$61498;J61459; $K$61381:$K$61498;"Quebra"))

  2. #2
    Forum Guru
    Join Date
    08-28-2014
    Location
    USA
    MS-Off Ver
    Excel 2019
    Posts
    14,084

    Re: Usar texto(endereço absoluto) presente em uma célula como critério em outras fórmulas

    Hello DHero and Welcome to Excel Forum.
    Not promising that I or anyone here can resolve the issue of finding the upper and lower limits for your formulas, however we may be in a better position to do so if we could see a small sample of the worksheet from which the screenshot in post #1 was made.
    Instructions for uploading an Excel file are given in the "HOW TO ATTACH YOUR SAMPLE WORKBOOK" banner at the top of the page.
    Let us know if you have any questions.
    Consider taking the time to add to the reputation of everybody that has taken the time to respond to your query.

  3. #3
    Valued Forum Contributor
    Join Date
    10-19-2021
    Location
    Brazil
    MS-Off Ver
    Office 365 w/ Win7
    Posts
    562

    Re: Usar texto(endereço absoluto) presente em uma célula como critério em outras fórmulas

    Me parece q seria o caso de usar INDIRETO().

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Atualizar macro para usar unicode UTF-8
    By Santosjj in forum Non English Excel
    Replies: 0
    Last Post: 01-24-2021, 12:57 PM
  2. Atualizar macro para usar unicode UTF-8
    By Santosjj in forum Excel Programming / VBA / Macros
    Replies: 0
    Last Post: 01-24-2021, 12:57 PM
  3. Vba copiar e colar dados conforme critério
    By refernande in forum Non English Excel
    Replies: 1
    Last Post: 04-29-2020, 05:12 AM
  4. Replies: 0
    Last Post: 01-20-2013, 09:16 PM
  5. Coloreando Números Según un Criterio Específico
    By ExcelTip in forum Tips and Tutorials
    Replies: 0
    Last Post: 11-28-2005, 06:57 AM
  6. Replies: 0
    Last Post: 11-28-2005, 06:55 AM
  7. texto
    By luciliacouto in forum Excel General
    Replies: 0
    Last Post: 07-13-2005, 05:05 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1