+ Reply to Thread
Results 1 to 3 of 3

.Send menthod not working for secondary calendars, failing with no error in debugger.

  1. #1
    Registered User
    Join Date
    05-05-2017
    Location
    Minnesota
    MS-Off Ver
    O365, 2016
    Posts
    11

    .Send menthod not working for secondary calendars, failing with no error in debugger.

    Hi All -

    I am struggling with the very last action in a set of macros I'm writing. Below is the full code. This is all written in ThisOutlookSession. There is something I don't understand about the .Send method, and after spending several hours looking at forums and reading Microsoft's documentation, I can't figure it out. Any help (including references to some other documentation I might not have found) would be greatly appreciated.

    Intent: this code is supposed to watch for things that get created (either by me, or by receiving an invitation) on my main work calendar and, if they meet a set of conditions (e.g. being at 8pm local time) copy it over to a secondary calendar, turn it into a meeting item by adding (my own) gmail address as a recipient, and then send it. This is important because I don't want everyone who sends me a meeting invite to get a forward notification every time I need to keep track of that particular meeting on my personal calendar as well as my work (outlook) one.

    Currently, I do this manually by looking at each item, and then copy/pasting over to the sync calendar, and then clicking the "Forward" button in the ribbon, typing my own email address, and hitting send. I am fairly certain that Outlook code should be able to replace that set of actions! As of right now, the code runs all the way through with no issues, and the AppointmentItem in the newCalFolder shows the correct email address as a meeting attendee, but that email address never receives the event. If I open the macro-created-meeting in the newCalFolder and click forward and add the same email address again and click send, it works.

    What am I missing?

    Thanks in advance!
    Parkanian

    Please Login or Register  to view this content.
    Last edited by Parkanian; 11-14-2019 at 09:30 AM.

  2. #2
    Forum Moderator Pepe Le Mokko's Avatar
    Join Date
    05-14-2009
    Location
    Belgium
    MS-Off Ver
    Excel 2010 on Linux
    Posts
    8,678

    Re: .Send menthod not working for secondary calendars, failing with no error in debugger.

    Administrative Note:

    Welcome to the forum.

    We would very much like to help you with your query, however you need to include code tags around your code.

    Please take a moment to add the tags. Posting code between tags makes your code much easier to read and copy for testing, and it also maintains VBA formatting.

    Please see Forum Rule #2 about code tags and adjust accordingly. Click on Edit to open your post, then highlight your code and click the # icon at the top of your post window. More information about these and other tags can be found here

    (Note: this change is not optional. No help to be offered until this moderation request has been fulfilled.)
    You really don't have to give me rep points for moderating. It's part of the job. Keep rep points for those who find solutions

  3. #3
    Registered User
    Join Date
    05-05-2017
    Location
    Minnesota
    MS-Off Ver
    O365, 2016
    Posts
    11

    Re: .Send menthod not working for secondary calendars, failing with no error in debugger.

    Hi Pepe. Done, and thank you for pointing it out.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1