+ Reply to Thread
Results 1 to 8 of 8

Posting Problems

  1. #1
    Registered User
    Join Date
    12-18-2012
    Location
    Jakarta
    MS-Off Ver
    Excel 2011 for Mac
    Posts
    34

    Posting Problems

    Is anyone getting this problem? If so, how do I get around it when trying to post a question that includes some VBA code that is wrapped in the code tags?

    This is what I get when I try to post:

    Sucuri WebSite Firewall - CloudProxy - Access Denied
    What is going on?
    You are not allowed to access the requested page. If you are the site owner, please open a ticket in our support page if you think it was caused by an error: https://support.sucuri.net. If you are not the owner of the web site, you can contact us at cloudproxy@sucuri.net. Also make sure to include the block details (displayed below), so we can better troubleshoot the error.
    Block details
    Your IP: REMOVED
    URL: http://www.excelforum.com/newthread....postthread&f=7
    Your Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36 OPR
    Block ID: SQLi17
    Block reason: SQL injection was detected and blocked.
    Time: Wed, 15 Jun 2016 00:37:17 -0400
    Server ID: cp11015
    Sucuri CloudProxy
    CloudProxy is a WebSite Firewall from Sucuri. It stands between your site and the rest of the world and protects against attacks, malware infections, DDOS, brute force attempts and mostly anything that can harm it.

    Not only that, but your sites get cached, speeding it up quite a bit. Interested? Visit http://cloudproxy.sucuri.net

  2. #2
    Registered User
    Join Date
    12-18-2012
    Location
    Jakarta
    MS-Off Ver
    Excel 2011 for Mac
    Posts
    34

    Re: Posting Problems

    As I posted this without issue, it looks like I get the problem because I have the VBA code in the post I am trying to make.

    The red highlight above is mine.

  3. #3
    Registered User
    Join Date
    12-18-2012
    Location
    Jakarta
    MS-Off Ver
    Excel 2011 for Mac
    Posts
    34

    Re: Posting Problems

    I have tried again to post my question, this time from a different computer running from a different internet provider and I still get this problem when trying to post the VBA code wrapped in code tags.

  4. #4
    Forum Expert Doc.AElstein's Avatar
    Join Date
    05-23-2014
    Location
    '_- Germany >Outside Building things.... Mostly
    MS-Off Ver
    Office 2003 2007 2010 PC but Not mac. XP and Vista mostly, sometimes Win 7
    Posts
    3,618

    "Space Trick" and "Black color trick" to overcome Sucuri Problem

    Hi RatHat,

    Sometimes Sucuri does not like certain combinations of characters. In a code the solution is usually to add a space at the offending place.
    So you paste the code in Code Tags with the extra space at the appropriate point.
    Usually this will not cause a problem when someone tries to use your code as the VB Editor will usually automatically remove the space when the code you give is pasted into the VB Editor

    _...............

    Check these Threads out for more detail:

    http://www.excelforum.com/showthread...t=#post4295092

    http://www.excelforum.com/the-water-...ml#post4226385

    http://www.excelforum.com/the-water-...ml#post4283991

    http://www.excelforum.com/suggestion...-a-thread.html

    So you may need to use the “space trick” discussed in those Threads somewhere in your code.
    _................

    If you find out what is the offending character combination in your code, then please feed back and let us know

    _ - Up until now we know of 2 things:

    _1) Replace___(Replace
    _____- the problem occurs if there is no space in between ( which is what you would normally do of course in a code )

    _2 ) A less than sign with some combination of 4 characters

    Alan.

    _............................

    P.s.1
    It may be best to experiment posting with different character combinations and spaces here in the Test Sub Forum:
    http://www.excelforum.com/development-testing-forum/
    http://www.excelforum.com/showthread...27#post4412527
    http://www.excelforum.com/developmen...ml#post4114849
    Just post a small bit of your code. Then post more and more of the code until the problem occurs. Then you will be able to locate the offending character combination.
    That is how I “discovered” the Replace___(Replace problem. Try posting exactly this:

    Replace(Replace

    It should give you the Sucuri problem ( Note here I have used the “Black Character trick” to make it look to you as if I have written it normally. – In fact it looks like this in the Editor before posting, as I “coloured” an arbitrary character “Black”!!:

    Replace(R[COLOR="#000000"]e[/COLOR]place

    P.s 2
    ( Note: usually the problem will occur if the character combination is anywhere in the Post, not just in the Code Window )
    '_- Google first, like this _ site:ExcelForum.com Gamut
    Use Code Tags: Highlight code; click on the # icon above,
    Post screenshots COPYABLE to a Spredsheet; NOT IMAGES PLEASE
    http://www.excelforum.com/the-water-...ml#post4109080
    https://app.box.com/s/gjpa8mk8ko4vkwcke3ig2w8z2wkfvrtv
    http://excelmatters.com/excel-forums/ ( Scrolll down to bottom )

  5. #5
    Registered User
    Join Date
    12-18-2012
    Location
    Jakarta
    MS-Off Ver
    Excel 2011 for Mac
    Posts
    34

    Re: Posting Problems

    Many thanks Alan,

    Been waylaid for the past week or so with work so will get back to this and try to see where the glitch is. Now that you have reminded me, I remember using the colour coding fix for other issues when posting on different sites, so this may well do the trick for me.

  6. #6
    Forum Expert Doc.AElstein's Avatar
    Join Date
    05-23-2014
    Location
    '_- Germany >Outside Building things.... Mostly
    MS-Off Ver
    Office 2003 2007 2010 PC but Not mac. XP and Vista mostly, sometimes Win 7
    Posts
    3,618

    Re: Posting Problems

    Quote Originally Posted by RatHat View Post
    .....Many thanks Alan,
    ....Now that you have reminded me, I remember using the colour coding fix for other issues when posting on different sites, so this may well do the trick for me.
    You is welcome, thanks getting back

    I have never noticed these problems anywhere else.
    But I do not post much anywhere else anymore!
    But interesting that you note problems elswhere. I always thought problems were the Hallmark Chartacteristic of Excel Forum Lol..

    Alan

  7. #7
    Registered User
    Join Date
    12-18-2012
    Location
    Jakarta
    MS-Off Ver
    Excel 2011 for Mac
    Posts
    34

    Re: Posting Problems

    Alan,

    I used to help on a couple of anti virus forums, and there would sometimes be issues posting script code, so this was also a good workaround to "fool" the filters without altering the actual content. It also worked well where links were not advisable to be clickable by posting http instead of http.

  8. #8
    Forum Expert Doc.AElstein's Avatar
    Join Date
    05-23-2014
    Location
    '_- Germany >Outside Building things.... Mostly
    MS-Off Ver
    Office 2003 2007 2010 PC but Not mac. XP and Vista mostly, sometimes Win 7
    Posts
    3,618

    Re: Posting Problems

    Quote Originally Posted by RatHat View Post
    .... worked well where links were not advisable to be clickable by posting http instead of http.
    That sounds handy_....
    Alan

    _....P.s. Good also for getting past the censoring of naughty words .. lol

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Posting
    By CodeMonkeys in forum Hello..Introduce yourself
    Replies: 1
    Last Post: 02-26-2014, 08:53 PM
  2. Add-In for posting
    By shg in forum Tips and Tutorials
    Replies: 4
    Last Post: 08-28-2013, 12:16 AM
  3. [SOLVED] Problems with sorting andf Pivot Table problems
    By Saturn in forum Excel General
    Replies: 4
    Last Post: 10-07-2012, 07:47 AM
  4. Replies: 0
    Last Post: 12-25-2011, 04:30 PM
  5. Try posting here
    By BlastRanger in forum The Water Cooler
    Replies: 1
    Last Post: 11-12-2010, 07:39 AM
  6. please help someone (again posting)
    By Tufail in forum Excel Programming / VBA / Macros
    Replies: 1
    Last Post: 07-04-2006, 11:30 PM
  7. [SOLVED] the owner of posting should be able to delete the posting
    By Mahendra in forum Excel General
    Replies: 7
    Last Post: 08-08-2005, 03:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1