+ Reply to Thread
Results 1 to 6 of 6

Localizar numero entre duas colunas

  1. #1
    Registered User
    Join Date
    02-19-2019
    Location
    brasil
    MS-Off Ver
    excel 2016
    Posts
    6

    Localizar numero entre duas colunas

    Boa tarde!

    Tenho uma planilha onde uma coluna A “Nota Fiscal” NF e na coluna B e C tem o Valor “MINIMO” e “MAXIMO” EX: NF A de 1 a 10, NF B de 11 a 20, NF C de 21 a 30… e tenho uma coluna com números aleatórios 7, 21, 34, 12, 46, 16, 24, 19.

    tenho utilizado as formulas para identificar quais dos números da coluna G estão dentro das NF utilizando as formulas abaixo, porem se o numero não faz parte de nenhuma NF ele atrela a mais proxima, saberiam me ajudar para que não mostre nada quando não encontrar?

    OBS: essa planilha pode ter mais de 10 mil linhas.

    excel 2.JPG

  2. #2
    Registered User
    Join Date
    02-19-2019
    Location
    brasil
    MS-Off Ver
    excel 2016
    Posts
    6

    Re: Localizar numero entre duas colunas

    formulas que ja utilizei:

    =ÍNDICE($A$2:$A$1000;CORRESP(F2;$B$2:$B$1000;1))

    =PROCV(F2,$B$1:$D$6,3,1)

  3. #3
    Forum Guru shg's Avatar
    Join Date
    06-20-2007
    Location
    The Great State of Texas
    MS-Off Ver
    2003, 2010
    Posts
    40,669

    Re: Localizar numero entre duas colunas

    In English,

    A
    B
    C
    D
    E
    F
    1
    Initial
    2
    0
    7
    A
    D2: =LOOKUP(C2, $A$2:$A$9, $B$2:$B$9) & ""
    3
    1
    A
    21
    C
    4
    11
    B
    34
    5
    21
    C
    12
    B
    6
    31
    73
    7
    41
    D
    46
    D
    8
    51
    E
    16
    B
    9
    61
    24
    C
    10
    99
    Last edited by shg; 02-26-2019 at 12:57 PM. Reason: Typo
    Entia non sunt multiplicanda sine necessitate

  4. #4
    Registered User
    Join Date
    02-19-2019
    Location
    brasil
    MS-Off Ver
    excel 2016
    Posts
    6

    Re: Localizar numero entre duas colunas

    Não compreendi o final da formula.

    está correta assim? =LOOKUP(C2,$A$2:$A$9,$B$2:$B$9)e""

    porque não consegui utilizar.

  5. #5
    Forum Guru shg's Avatar
    Join Date
    06-20-2007
    Location
    The Great State of Texas
    MS-Off Ver
    2003, 2010
    Posts
    40,669

    Re: Localizar numero entre duas colunas

    See attached. The formula should translate when you open it.
    Attached Files Attached Files

  6. #6
    Forum Moderator alansidman's Avatar
    Join Date
    02-02-2010
    Location
    Steamboat Springs
    MS-Off Ver
    MS Office 365
    Posts
    20,186

    Re: Localizar numero entre duas colunas

    crosssposted: https://www.mrexcel.com/forum/questi...s-colunas.html

    Rule 03: Cross-posting Without Telling Us

    Your post does not comply with Rule 3 of our Forum RULES. Do not cross-post your question on multiple forums without telling us about your threads on other forums.

    Post a link to any other forums where you have asked the same question.

    Cross-posting is when you post the same question in other forums on the web. The last thing you want to do is waste people's time working on an issue you have already resolved elsewhere. We prefer that you not cross-post at all, but if you do (and it's unlikely to go unnoticed), you MUST provide a link (copy the url from the address bar in your browser) to the cross-post.

    Read this to understand why we ask you to do this.

    I have added the crosspost reference for you today. Please comply with this and all our rules in the future

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. localizar valor entre intervalo de 2 valores
    By dugsblack in forum Non English Excel
    Replies: 9
    Last Post: 02-20-2019, 06:43 PM
  2. localizar valor entre intervalo de 2 valores
    By dugsblack in forum Excel Formulas & Functions
    Replies: 0
    Last Post: 02-19-2019, 10:25 AM
  3. Colunas Agrupadas em abas diferente
    By ljrbrasil in forum Non English Excel
    Replies: 5
    Last Post: 05-18-2012, 10:24 AM
  4. Cambiando el Número Predeterminado de Hojas en un Nuevo Libro
    By ExcelTip in forum Tips and Tutorials
    Replies: 0
    Last Post: 11-28-2005, 09:55 AM
  5. Cambiar el Formato de la Celda de Fecha a Número
    By ExcelTip in forum Tips and Tutorials
    Replies: 0
    Last Post: 11-28-2005, 06:54 AM
  6. [SOLVED] celda con numero IP
    By Gilberto in forum Excel General
    Replies: 1
    Last Post: 11-02-2005, 06:17 PM
  7. Cambiar de numero a letra.
    By japerezestebaran in forum Excel General
    Replies: 1
    Last Post: 10-31-2005, 06:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1