+ Reply to Thread
Results 1 to 5 of 5

Getting an variable index as a function parameter

  1. #1
    Registered User
    Join Date
    08-22-2008
    Location
    Fortaleza
    Posts
    2

    Getting an variable index as a function parameter

    Hi guys,

    I've one question I guess it's pretty simple to solve, but I don't know Excel very well, all my knowledge on that subject comes from programming. So, I have this function that retrieves data from another spreadsheet, but it depends on what line the data is, so the first line looks like that:

    =SOMA(Mod1M:Mod5T!B1:F1)

    The second:

    =SOMA(Mod1M:Mod5T!B2:F2)

    The N-th:

    =SOMA(Mod1M:Mod5T!BN:FN)

    So, what I want is to use the function LIN(), that returns the actual line, in the functions arguments. How I do that?

    Thanks for the help.

  2. #2
    Forum Guru shg's Avatar
    Join Date
    06-20-2007
    Location
    The Great State of Texas
    MS-Off Ver
    2003, 2010
    Posts
    40,678
    I think I don't understand your question. If you put the first formula in a cell and copy it downward, the row references will change automatically.

  3. #3
    Forum Guru martindwilson's Avatar
    Join Date
    06-23-2007
    Location
    London,England
    MS-Off Ver
    office 97 ,2007
    Posts
    19,320
    well youre one up on me! i dont even understand the function or the question

  4. #4
    Forum Guru shg's Avatar
    Join Date
    06-20-2007
    Location
    The Great State of Texas
    MS-Off Ver
    2003, 2010
    Posts
    40,678
    I'm guessing SOMA is SUM and LIN is ROW, but whatever, the reference will change.

  5. #5
    Registered User
    Join Date
    08-22-2008
    Location
    Fortaleza
    Posts
    2
    Yeah, the reference will change. See? I'm such a newbie I didn't try pasting =)

    And yeah, SUM = SOMA; LIN (HA) = ROW, I'm using a brazilian version of office. Thanks

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Default value/text for variable in Function declaration
    By leecs in forum Excel Programming / VBA / Macros
    Replies: 2
    Last Post: 02-27-2008, 10:07 PM
  2. Using Autofill with Destination Parameter as a Variable
    By MartinShort in forum Excel Programming / VBA / Macros
    Replies: 2
    Last Post: 01-09-2008, 08:48 AM
  3. Link together different cells in specific order?
    By Sandman4432 in forum Excel Formulas & Functions
    Replies: 19
    Last Post: 01-03-2008, 05:01 AM
  4. Index function with if statements
    By eleventhal in forum Excel General
    Replies: 2
    Last Post: 09-26-2007, 05:35 PM
  5. Pass sub variable to function
    By ledzepe in forum Excel General
    Replies: 3
    Last Post: 12-06-2006, 03:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1